Friday, August 24, 2018

Install Ruby untuk koneksi ke Postgresql di Ubuntu

Install Ruby pakai APT
sudo apt-get install ruby-full
sudo apt-get install ruby-all-dev

Kemudian install library PG (semacam driver Postgresql untuk Ruby) melalui gem
sudo apt-get install libpq-dev  (karena nanti dibutuhkan oleh gem pg)
sudo apt-get install rubygems-integration

Baru kemudian install library pg menggunakan gem.
sudo gem install pg

per-Januari 2018 (dan masih bermasalah di Agustus 2018) tampaknya library ini retak.

sudo gem install pg -v 0.21.0 -- --with-pg-config=/usr/bin/pg_config

sumber: https://github.com/sous-chefs/postgresql/issues/462

0 comments: